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Preorder payment solution is easy to install on OpenCart framework. 

Merchants have to perform following Steps: 

1. Download “PUT IT ON PRE-ORDER (powered by PayPal)”  

2. Register at https://lay-buys.com/  as merchant 
3. Installing “Preorder Payment Gateway Extension for OpenCart” 

Step 1: Download “PUT IT ON PRE-ORDER (powered by PayPal)” 

 Download the latest package from OpenCart - Extensions Market  

Step 2: Register at lay-buys.com as merchant 
 Sign-up on https://lay-buys.com/vtmob/register.php 

 Then fill your PayPal credentials (see account page) 

 

https://lay-buys.com/
http://www.opencart.com/index.php?route=extension/extension
https://lay-buys.com/vtmob/register.php
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Step 3: Installing “PUT IT ON PRE-ORDER (powered by PayPal)” 

 Upload all the files and folders to your server from the "PUT IT ON PRE-ORDER (powered by 

PayPal)" folder. This can be parrallel to "admin" and "catalog" folders. 

e.g. /public_html/store or /public_html 

 Now go through admin panel and install the extension 

  Step 1 - Go through menu "Extensions > Payments", 

 Step 2 - Click on [Install] link under Action column in 'PUT IT ON PRE-ORDER (powered by 

PayPal)' row, 

 Step 3 - Then Click on [Edit] link under Action column in ''PUT IT ON PRE-ORDER (powered 

by PayPal)' row for Set the general configuration, 
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Please go to admin panel -> Extensions -> Payments -> [Edit] in 'PUT IT ON PRE-ORDER (powered by PayPal) row to manage the payment 
method settings. 
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Field-wise description: 

 

 Preorder Membership Number is a unique id provided from lay-buys.com on a merchant account creation. 

 Gateway Url is the POSTing url for process order payment, provided with extension kit. 

 Bypass Preorder Hosted Page is the field for by pass the payment flow from Preorder directly send to PayPal. 

 Minimum is the minimum down payment percentage allowed for a down payment.  

 Maximum is the maximum down payment percentage allowed for a down payment. 

 Months field is the maximum cycle for payment instalment. 

 Total The checkout total the order must reach before this payment method becomes active. 

 Order Status is the order status for newly created order using this payment method. 

 Allowed Categories The checkout products of the orders must be in these categories before this payment method 

becomes active. 

 Allowed Customer Groups The checkout customer must be in these customer groups before this payment method 

becomes active. 

 Geo Zone is the allowed zone for method availability. 

 Status field toggle the payment method availability for checkout step at OpenCart shopping cart. 

 Sort Order is the displaying order among all the payment methods at “Payment Method” step in checkout steps.   

 Instalment Report Setting 

o Api Credentials  

 Api IP-Address is the url for fetching the instalment report from lay-buys server, provided with this 

payment extension. 
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Note: As you can assume, this extension will only work if your store allows pre-order.  

To allow pre-order go to: System > Settings > Store[Edit] > Option > Stock Checkout,  

and set Stock Checkout => “Yes”  
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At Checkout Page in OpenCart Front-end: 

 

Payment Method Step 

  

Preorder Payment method is appear in checkout step when a buyer checkout the order. 

 

When a customer choose “PUT IT PRE-ORDER powered by 

PayPal” payment method as their payment option in payment 

step under checkout page, then customer have to choose the 

instalment plan for his/her payment by choosing some down 

payment percentage and choose months for creating 

instalment payment for 1,2 or 3 months at “Confirm Order” 

step. 
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Confirm Order Step 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Here customer can choose any plan for payment by choosing Initial Downpayment percentage and Months for next 

instalments. 
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Instead of one single “Place Order” button , there are two buttons will appeared in this step, first one is “Put it on 

Preorder” and second one is “Confirm Order” when customer chooses  

the “PUT IT PRE-ORDER powered by PayPAl” as their payment option in Payment Method  

Step at checkout page. 

 

Both buttons server same purpose that is place a order on OpenCart website and then redirect to PayPal for payment . 

Instead of paying all the amount(grand total of order), customer have to pay the down payment amount  and then a 

recurring profile will created on PayPal for next payments. 

 

On successful payment a success page will appeared at OpenCart website by showing success information and on failure 

a OpenCart order will not placed and show checkout page for retry
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Preorder Instalment Reports are the transaction reports which contain all the information related to Preorder 

detail, PayPal transaction detail, customer detail, order detail and instalment detail. When a customer choose Preorder 

payment option as their payment method in payment step under checkout page, then customer have to choose the 

instalment plan for his/her payment by paying some down payment and create instalment payment for 1,2 or 3 months. 

So every transaction will stored in OpenCart website and can be managed form a panel called “Preorder 

Instalment Reports”. 

Please go to admin panel -> Extensions -> Payments -> [Edit] in PUT IT ON PRE-ORDER (powered by PayPal) row to manage the 
instalment reports.
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Column-wise description: 

 Created At is a date time field and store the created date of transaction. 

 Order# is the order id related with the transaction. 

 Amount is the grand total of order. 

 Down Payment % is the percentage of down payment. 

 Months is the total no of instalment cycles. 

 Downpayment Amount is the down payment amount (calculated from down payment %) paid at time of order 

placing.  

 Payment Amounts is the next instalments amount.  

 First Payment Due is the date of first payment. 

 Last Payment Due is the date of last payment. 

 Status is the status of transaction. It may be Pending/Completed/Cancelled/Revised Request/Revised 

 

When a transaction have pending instalments then its status will be “Pending” , if transaction have no pending 

instalments means all instalments get paid then its status will be “Completed”. If transaction is cancelled due to some 

reason then its status will be “Canceled”. 

Admin can revise the instalment skim by sending a request mail to buyers, so when a transaction is just requested 

then its status will be “Revise Requested” when buyers accept and process the transaction then its old transaction get 

a status that is “Revised” and a new transaction row will appeared for same order with a status “Completed/Pending”. 

Detailed explanation about Status is discussed in next topics. 
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Fetch Updates is the functionality for fetching the latest report of instalments from http://lay-buys.com. 

At “Preorder Instalment Reports” panel, there is a button at top-right corner named as “Fetch Updates”. 

Fetch Updated send a request for all transactions which have Pending status.  

On success there will be a success message appeared with total fetched count at message area as: 

http://lay-buys.com/
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6. View Transaction Details   

 

 

View Transaction Details of a transaction is the detail page of the transaction. If admin want to see the complete 

detail of transaction then admin have to click on [View] in appropriate row from “Preorder Instalment Report” table . 

The detail page is look like as : 

 

 

 

 

 

 



Copyright LAY-BUYS (2011). (http://lay-buys.com/) 
 

 

User Guide: Pre-Order Payment Gateway Extension for OpenCart 
Support: http://lay-buys.com 

 

Page 15 
| P a g e  

6. View Transaction Details   

 

 

Field-wise description: 

 Reference Information :    

 PayPal Profile ID is the recurring profile id from PayPal. 

 Preorder Reference ID is unique id from Preorder related to current transaction. 

 Order ID is the order id related to current transaction.  

 Payment Plan : 

 Status is status of current instalment plan. 

 Amount is the grand total of order. 

 Down Payment % is the percentage of down payment. 

 Months is the total no of instalment cycles. 

 Downpayment Amount is the down payment amount (calculated from down payment %) paid at time of 

order placing.  

 Payment Amounts is the next instalments amount.  

 First Payment Due is the date of first payment. 

 Last Payment Due is the date of last payment. 

 Payment Record is a tabular information about down payment and its instalments with date , transaction id 

and status. Status may be Completed/Pending/Cancelled. 

 Customer Information : 

 First Name is first name of customer. 

 Last Name is last name of customer. 

 Email is email of customer. 

 Address is address of customer. 

 Suburb is suburb of customer.  

 State is state of customer. 

 Country is country of customer.  

 Postcode is postcode of customer
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Cancel Transaction is the functionality of cancelling the current recurring profile form Preorder through PayPal 

as well as cancel the associated order of OpenCart website. 

For “Cancel Transaction” , there is a button at “View Transaction Details” page name as “Cancel Transaction”. 

So admin can click on this for cancelling the order and its recurring profile from Preorder and PayPal. 

 

 

 

 

Note: Only a Pending Transaction can be cancel.
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Revise Instalment Plan is the process of editing the current instalment plan. This functionality create a new 

transaction row with revised plan. For revising you can click on “Revise Instalment Plan” button appeared at “View 

Transaction Details” page. After clicking on that button a form will opened with editing options as :

 

 

Note: Only a Pending Transaction can be revised. 



Copyright LAY-BUYS (2011). (http://lay-buys.com/) 
 

 

8. Revise Instalment Plan 
 

User Guide: Pre-Order Payment Gateway Extension for OpenCart 
Support: http://lay-buys.com 

 

Page 18 
| P a g e  

   

 

 

  

 The Revise form contains the some information as editable and some of them read-only. Reference 

Information don’t need to be edit so that these  fields are read-only and these fields are used for reference on revising 

process. 

   Total Amount is the amount available for revising process, generally its calculated by formula  

Total Amount  = Grand Total of order – Total Paid Amounts 

Where, Total Paid Amounts = Down Payment + (no of completed instalment * Payment Amounts) 

Payment Type is the method of next payment. It may be Preorder or Buy-Now. 

 Preorder:  It create a new recurring profile for balance amounts. And cancel the current profile. 

 Buy-Now: It’s the method of paying all the balance amount at one time without any instalment plan. So when 

customer want to pay all the balance amount in one time then admin can choose this method for current 

customer. 

Initial Payment* is the down payment percentage for new plan. 

Months to Pay * is the no of instalment cycles for new plan. 

Preview* is the preview of your plan depend upon Initial Payment and Months to Pay fields. 

Email (read only) is the email of customer. It must be same through out OpenCart, Preorder and PayPal. And it is a 

important key for identify the customer data on Preorder and PayPal so it can’t be changed from here.   

 

*visible on “Preorder” option, if “Buy-Now” will choose these fields get disappeared because in Buy-Now is the one 

time payment method so no need of instalment information. 
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 After choosing new plan click on “Save and Send Email to Buyer” button for submit the request and send a 

mail to the customer’s email. Also current transaction status become “Revise Requested” . After success a message 

will appear with message “Request was saved and email sent to <customer_email> for order<order_id>”. 

 

According to “Payment-Type” the processing of revising will works. 

 

Progress for “Preorder” Method: 

 Email Structure: see example format  
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In mail content there will be a link for accepting revise request and pay the new down payment from PayPal. 

When customer click on the link they will redirected to PayPal and perform the transaction. After success 

customer redirect to OpenCart success page and a new transaction row will be added to transaction table with 

Status “Pending” . 

 

Progress for “Buy-Now” Method: 

 Email Structure: see example format  
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In mail content there will be a link for accepting revise request and pay the balance amount from PayPal at one 

time. When customer click on the link they will redirected to PayPal and perform the transaction. After success 

customer redirect to OpenCart success page and a new transaction row will be added to transaction table with 

Status “Completed” .
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  In Customer Account Section customer can also view their Instalment plans for a order. In “View your order 

history” section customer can view the details of the order by clicking on “View Icon” 
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Then a page will open which so the orders details. Under “Payment Method” section you can see a “PUT IT ON PRE-

ORDER powered by PayPal” as anchor link 
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If customer want to see the Instalment details then customer have to click on “PUT IT ON PRE-ORDER powered by 

PayPal” link. This link show all the Instalment plans choosen by customer for this order. 
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Customer also can view the full details of a Instalment plan by clicking on “View” link in appropriate row. 
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There are five kind of transaction statuses as: 

1. Pending, 

2. Completed, 

3. Cancelled, 

4. Revise Requested, and 

5. Revised. 

 

Pending when there is at least one instalment is pending or revise by Preorder method. 

Completed when all the instalment get paid or revise by Buy-Now method. 

  Cancelled when instalment not paid at right time or manually cancel by admin as “Cancel Transaction”. 

  Revise Requested when a transaction get just revise not completed by customer. 

  Revised when customer respond for Revise Request transaction then old transaction become Revised.  



Copyright LAY-BUYS (2011). (http://lay-buys.com/) 
 

 

User Guide: Pre-Order Payment Gateway Extension for OpenCart 
Support: http://lay-buys.com 

 

Page 27 
| P a g e  

  

 

 

 

 

 
 

Thank you! 
 

 

Should you have any questions or feature suggestions, please contact us at: 
 

http://lay-buys.com 
 

 
 
 
 
 

Your feedback is absolutely welcome! 
 

 
 

http://lay-buys.com/

